rocket record very unreliable

malh

Been using RF level 1 for a couple of weeks trying to refresh my schoolboy french.

The record function is a good idea as you can hear what you're saying and compare with the tutors if you don't instantly get a 100% score, but it only works occasionally.

I'm using Chrome (latest version) on Linux Mint and the microphone in my laptop.  I really don't think a headset microphone would help at all as occasionally if I try to playback what I said it sounds just like me talking, and there's no background noise, so it's not a hardware problem.   I've got a 32M-bit connection as measured by a engineer, and I'm connected via a LAN cable.

For example, today, on module 4.2 on the hear it say it test (second last one) the phrase was "Qu’est-ce qu’on cuisine dans la cuisine ?" and what I recorded sounded like "suptebabaja" spoken very quickly (it took several attempts for me to transcribe that) ; it's as if what I said was sampled at random intervals and most if it thrown away.  I just went back to it to check and I had to restart the lesson but now the record only has a few short segments missing, it sounds mostly like it should but as if it's on a mobile phone and breaking up a bit.  I started the exercise from the beginning and record started as very clear and seems to have deteriorated as I went through it, but that's just a guess.  I'll keep some notes and see if that pattern repeats.

I've been resorting to speaking slowly in a comedy accent to try to get past the AI, but I don't think that's a good way to learn.  Right now I'm thinking of recording on my phone as a work round but that's a big nuisance, any chance of a fix?

malh

I just reproduced he problem!

I carried on with 4.2, did the Write it test and then the Know it test.

At the start of the know it test my voice was recorded mostly OK but the playback kept getting shorter/faster/broken up as I went on.

By the second last one ("Qu’est-ce qu’on cuisine dans la cuisine ?") my rendering of that phrase turned into "kelontebabaja' spoken very quickly.

malh

.... so i tried the next lesson after having restarted chrome.

As expected record works fine to start with then bits start dropping out.
I did lesson 4.3, by '25 to go' on hear it say it you can tell bits are missing, by 10 to go it's playing back at 1.5 to 2x real speed with glitches, by 5 to go it's getting unrecognisable.


I carried on through Know it and confirmed that by  s p e a k i n g  v e e r r y y  s s l l o o w w l l y y you could get the VR to work, therefore it's loosing voice samples on the record path rather than the playback.

But I don't want to learn to speak slowly, I want it to flow.   :-(

malh

Further experiments reveal that if you close and restart Chrome (logging out and back in is no use), then the record goes back to working.

However to get any sensible response from the VR without talking like a retard you have to restart after about 20 phrases.   This is a real PITA.

I tried firefox (latest version,  I just updated it) instead and you can get through a vocabulary section (play the tutor, record and listen back) quite easily, but when you move onto 'hear it say it' you can't hear anything, ie the playback of the tutor is completely silent, so that's just not usable.

marieg-rocket languages

Hi Mahl, 

Thank you for reporting the problem. Could you please send us an email to  [email protected] with the following image: 

1. Try to record and playback something. 
2. If it doesn't work, hit the F12 key and select the 'Console' tab. 
3. Reload the page and try to record and playback again. 
4. If a message in red comes up, please take a screenshot and send it to us. 

We can then review the problem with our tech support team. 

Kind Regards. 
 

malh

Thanks for doing some fix.

I've gone over yesterdays exercises (my first repeated session!) and it seems that now after about 20 phrases the record process gets reset and goes from slightly broken up back to clear and it also seems to reset at the start of an exercise.  

So that looks like a good work-around.   I'm prepared to believe there's a bug in chrome rather than RF, I used to fix software myself ;-)

Just for the record, if Rocket Record does degrade, then reloading the page with the chrome recycle button also appears to reset it.

Thanks

Ask a question or a post a response

If you want to ask a question or post a response you need to be a member.

If you are already a member login here .
If you are not a member you can become one by taking the free Rocket French trial here .